Forum: Magellan GPS
Topic: help! sportrak map - cant upload basemap!
started by: jens

Posted by jens on June 19 2003,5:09 am
Hello!
I have a sportrak map (2m base, 6m detail) that was working just fine- that is until I somehow corrupted the basemap, and now I CANNOT upload any basemap onto the unit.

First, I had it working with firmware 4.06 and NA base 1.10?, but I needed the Euro base, so I sucessfully uploaded the eu_b100.img (2meg), and was using the euro base map without any problems.. My problems happened when I tried to upload a large euro basemap (7meg) not realizing that I couldnt and shouldnt do that..
Well, that did not upload properly, so I followed the procedures for erasing serial flash.. (option 95) that was supposed to erase all the map data, so that I can re-upload a good basemap? right?

Well, now I cannot upload ANY basemaps. the unit stays on "unit currently contains no map, initiating map upload" and when I try to use expert mode (MAGUP) to upload "base map only" it starts the  upload but hangs at 0 % on "CREATING LINK" and never goes past zero percent.

I have also tried clearing the memory and re-clearing the serial flash (95). Also tried using #98 to upload basemap, but same problem: stuck at "CREATING LINK" in magup.exe
I have tried option 99 as well, and reloading the firmware 4.06 (I can reload firmware with no probs), and then trying to load the basemap, but still nothing..

Also, it is worth noting that I can upload "detail map" from option 98, i just cant upload "base map" ? :(

Is there a way to use hyperterm to see what is going on?
Is my serial flash totally corrupted? Any way to fix this without sending back to magellan..?

ALSO: in the DEBUG.OUT log file that MAGUP.EXE generates, im noticing a repeating:

HAND - hello
HAND - error 0084
HAND - error 0084

that keeps repeating over and over, as if it can never setup communication.



also, just a friendly reminder to those who play with basemaps... im not sure what went wrong, but BE VERY CAREFUL when messing with them, you might end up in my situation!!


Jens J.



Posted by jens on June 19 2003,7:42 pm
update:
Well I have found a few more "hidden menus"
#96 causes an info dump of the filesystem about flash mem to the serial port... (#97 seems to be a hex dump of the data on the file system??)

I think i have found the problem, although I dont know how to fix it.. and magellan would like me to send it back $$$$$..
It looks like the file na_1_01.dat is a corrupt (0 bytes) file, however when I do #95 (serial flash erase) it will never dissapear.. I also tried the magellan command: $PMGNCMD,FIL,DELETE,na_1_01.dat*48
but it keeps saying UNABLE to delete..
Man I know there has got to be a way to "format" the onboard flash? move the file, write a few bytes to it, do something to get it moving??
also, I was thinking, that: when i upload any "detail" map, it writes it to flash as "SECNDMAP.DAT", and the base map is supposed to be "FIRSTMAP.DAT"... there has to be a way to rename SECNDMAP.DAT to FIRSTMAP.DAT
Im pretty sure that the magellan is looking for the FIRSTMAP.DAT file on startup and not finding it is sending it into "basemap upload mode"


here is my output of #96:

SMC

IS VALID FAT12 SYSTEM



 Bytes per sector:      512

 Sectors per cluster:       16

 Number of FATs:        2

 Entries in directory:      256

 Max. cluster:     1019

 Sectors per FAT:        3

 Bytes per page:      512

 Pages per block:       16

 Pages per sector:        1

 Sectors per block:       16

 Blocks per cluster:        1

 Pages per cluster:       16

 Boot sector:        9

 FAT sector:       10

 Directory sector:       16

 Pages in directory:       16

 Data offset page:        0

 Partition?:        1

 Device full?:        0

FILES:



na_1_01 .dat           0 bytes    00:00:00   0/00/1980

CLUSTER CHAIN:





MEMORY  .DAT      212992 bytes    09:00:40   3/19/2003  A

CLUSTER CHAIN:

    3      4      5      6      7      8      9     10     11     12

   13     14     15     16     17     18     19     20     21     22

   23     24     25     26     27     28     29





BAD CLUSTERS:



CHECKING FOR LOST CLUSTERS

NONE FOUND



MMC

can not be found



DONE

Posted by Quinn on June 19 2003,9:17 pm
I would think that if you can get the unit into an upload mode you should be able to just reload the latest version offered by magellan.

Do you have the set to get you into this mode?

most Magellans are "ESC", "GOTO", at the same time while turning on the power.

Posted by jens on June 20 2003,4:18 am
thanks quinn,
but yeah, i have tried just about everything, and I cant understand why it wont upload... I believe that my flash file structure is somehow corrupted


I'd actually love to see what files "working" sportraks have on their flash..

id think they should have

memory.dat
firstmap.dat
secndmap.dat

Looks like im gonna pay the piper on this one

J

Posted by lotos on Oct. 02 2003,1:37 pm
SuperUp!!!
$PMGNCMD,MPUPLOAD,3*57 :p

Posted by Cracker7M on Oct. 03 2003,6:31 am
Jens, I think you might be overthinking this....

I have had this happen with both my Merigreen and ST Map...

Are you using expert mode on magup? Are you checking the radial button to download the firmware AND the basemap?

It usually takes a couple tries, but this always seems to work for me....

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.